Surface3d討論版

Rhino專家 -- 曲面實業
Google  
現在的時間是 週一 12月 10, 2018 4:33 pm

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 22 篇文章 ]  前往頁數 12  下一頁
發表人 內容
 文章主題 : VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週二 4月 12, 2011 1:08 am 
離線
user

註冊時間: 週二 4月 12, 2011 12:12 am
文章: 2
VFR里的Zdepth渲染出来没有灰度啊,就纯白一片,求解
模型用的是<VRAY你的RHINO>里的景深模型....VFR是1.60.16版本的...設置沒更改


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週二 4月 12, 2011 2:15 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
檔案打開後直接render,沒有任何問題。
附加檔案:
Chair_DOF.png
Chair_DOF.png [ 41.87 KiB | 被瀏覽 170 次 ]


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週二 4月 12, 2011 9:09 pm 
離線
user

註冊時間: 週二 4月 12, 2011 12:12 am
文章: 2
悲劇.....還是打開直接渲染,依然一片白色,還上不了圖...顯示——副檔名 是禁止使用的。 (010)


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週二 4月 12, 2011 10:33 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
附加檔案可以使用jpg, png, gif這些圖片檔案格式,你無法在選取圖檔後從"增加檔案"那個按鈕上傳檔案嗎?


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 12:03 pm 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
老師您好:

想請教這樣渲染出來導致畫面一片白色的原因為何?
謝謝!


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 5:06 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
Z-Depth選單下方那個Black與White的數值是用來對應目前攝影機的焦距(White)與景深作用範圍(Black),設置正確的數值才能產生正確的Z-Depth景深灰階圖。

圖檔


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 5:50 pm 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
謝謝老師的回覆:

我想我搞錯了!我的問題應該不在這,不過我在這裡爬文並未找到更相似的文章!
前時曾經寄來一個船身,現在我完成這艘船,不過彩現一直有問題!而且狀況複雜..
數天來解決了些自己並不很明白的問題!現在就剩彩現畫面呈現一片白色!實在不明瞭
原因何在?懇請老師幫忙解惑!..謝謝!


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 6:09 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
材質設好了、燈光也打了,然後彩現圖一片白?

請再檢查看看:
1. 場景有被什麼東西整片擋住?
2. 燈光強度過亮?
3. 光圈、快門的曝光條件錯誤?
4. 按到V-Ray frame buffer上方那個"Switch to alpha channel"按鈕忘了切回來?
5. 換不同視角都一樣?
6. 關閉Rhino、重開後載入模型檔彩現結果還是一樣?
7. 你的電腦時間設定在農曆鬼月?


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 8:55 pm 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
回覆老師:

材質設定好了,未打燈光(習慣先靠GI,沒問題後才會設燈光),確是彩現後一片白!

1.場景沒有東西擋住!
2.尚未使用燈光!
3.未使用物理相機!
4.未按到alpha channel按鈕!
5.換任何視角都一樣!
6.重開載入都一樣!
7.時間日期正常!

昨天設定貼圖中曾經多次彩現看效果,可是會突然的當掉!當重新開機載入後前面貼圖作業被歸零!..然後無法算圖
如此反覆多次均無法解決!..後發現經使用的檔案變得非常大,由200餘MB變成1.4GB...經windows defender掃瞄
除去一有問題檔案程式後...雖然不當機.檔案不變大.但是彩現後一片白!..問題是開舊檔可以算圖.開新檔隨意設置
也可以算圖!..為此今天更新了V-Ray,也更新了顯卡驅動,結果這檔案還是無法演算!

彩現視窗出現時就是白色的僅僅在上端約1mm寬線帶是黑色隱約感覺它在動!但是很快到100%這與通常設定所需
演算需時不符合!


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週三 7月 04, 2012 9:10 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
愈看愈覺得好像在哪裡看過相同的問題..........我看只好請我們大陸的同事來幫你把脈吧


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週四 7月 05, 2012 12:27 am 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
謝謝老師:

雖然無法知道原因何在!但由老師回覆看來驗證可能有這樣問題!而不是我做錯什麼!
今晚將複製備用的幾個相同檔案一一試驗!結果都一樣!
如此一來這模型不就白做工了?
不會的!我想也許是Rhino與V-Ray之間的什麼問題!也許不是!也或許是這Rhino檔案損毀?也許不是?
我先前有輸出obj與3ds檔...開新檔案叫進3ds檔我損失了作業中在Rhino裡面整理的圖層!
但是在3ds檔模型上物件是依圖層分類的,所以處理貼圖雖然較累但是不到令人放棄的地步.
彩現試試...果然可以!不但可以檔案還從270MB左右變成70MB左右!


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週四 7月 05, 2012 2:18 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
請問:
1. 你的貼圖檔案有使用中文檔名的嗎?
2. 出問題的這個檔案內的所有物件就算已經完全不使用材質還是都只能得到一片白色的彩現結果?
3. 出問題的版本是V-Ray 1.0 SR1.5版還是V-Ray 1.5?

請你給我完全沒有指定材質,彩現還是一片白色的那個檔案,我可以幫你看看是怎麼回事。
cafer@mcneel.com


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週四 7月 05, 2012 4:19 pm 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
老師您好:

1:貼圖檔名使用英文.(我也想過,也查看過,但是後來新開啟匯入3ds檔模型的檔案也使用相同材質所以應該不是這問題!)
2:後來是這樣!
3:是V-Ray 1.5

現在我已經算了些模型圖出來,目前正在整理海面場景圖,剛剛有一點感覺似是之前令人不安的感覺!但不是很確定!
我經常在調整物件之後會render一下看看,但是不會到它作業完便關掉render,然後又調整,又render,又關掉...這次
看到一個對話框(不記得以前是否看過)給它認識一下.它說請我等待現在彩現作業結束!可是我明明已經關閉彩現視
窗啊?於是我到"工作管理員"查看.發現正有兩個V-Ray在執行...會不會是之前未理會導致檔案出問題!
現在又出現問題!它又告訴我Rhino記憶體不足?當了...檔案是93mb而已...先行去看看再說了...

真是不好意思!
現在拼湊!它大概是會告訴說Rhino記憶體不足!之後當掉!有時還會警告檔案可能已經損毀!提醒要小心!
然後我會經由"rhino emergency_safe開啟檔案然後另存新檔...這新檔裡面設定會跑掉!材質全不見!可
是直接算圖時會看到模型有部份材質有些部份沒有材質.於是重新匯入材質逐一貼上再彩現.又當!再重來
如此折騰幾次...彩現對話框裡便一片空白...


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週四 7月 05, 2012 7:44 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1897
來自: Tainan
請把這個出問題的檔案寄給我。


回頂端
 個人資料  
 
 文章主題 : Re: VFR里的Zdepth渲染出來沒有灰度,就純白一片,求解
文章發表於 : 週四 7月 05, 2012 10:39 pm 
離線
user

註冊時間: 週六 5月 02, 2009 11:51 am
文章: 48
老師您好:

其實做為使用者在我來說已經是不錯了!要去理解程式的諸多問題實在離我太遠!
我在想會不會是我套用更新前所做的一些Render Options所致?剛剛將作品貼上
海景那張被拒絕使用高些的設定.Image sample Min subdivs 1 Max subdivs 4
當將其改為Min subdivs 8 Max subdivs 16 時出來的彩現畫面僅有海與天空!船
在彩現視窗裡消失!調更高就又當...其實這些設定做MHC時都極為輕易!

稍後我將寄出2個壓縮的不同檔案到YoKo小姐信箱

兩個檔案已經分別寄出了!


回頂端
 個人資料  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 22 篇文章 ]  前往頁數 12  下一頁

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 4 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯文章
不能 在這個版面刪除文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作