Surface3d討論版

Rhino專家 -- 曲面實業
Google  
現在的時間是 週日 4月 22, 2018 1:26 am

所有顯示的時間為 UTC + 8 小時




發表新文章 回覆主題  [ 21 篇文章 ]  前往頁數 12  下一頁
發表人 內容
 文章主題 : 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 10月 31, 2011 10:02 am 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
哈囉~各位先進 想請教一下
我在rhino裡建好模型也已使用了show edge指令並無間隙了,是唯一完整的封閉模型,但轉成step檔進入到sw與pro-e中發現部分有些相鄰的面還是有間隙的狀況,未能成為實體
初步懷疑是在rhino裡精度不夠(因圖案較為複雜,是一圓柱體上的側邊有浮雕的圖案) 導致join各個面時產生了細微的間隙,所以我想問的是精度該調整多少會比較合適呢??之前有用0.01與0.001的公差(有時交互改變,所以才產生問題的吧!)
請各位先進幫幫忙~感謝!
ps:使用rhino過程中,我有使用rhinoart與rhinoresurf搭配,不知是否會有影響模型的品質呢??不過間隙的狀況是都發生在面與面的接合處上!(其實我現在還不是很確定問題是出在哪裡呀)
礙於產品尚未量產,還未能公開,故無截圖,請多包涵!

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 10月 31, 2011 10:32 am 
離線
VIP

註冊時間: 週五 6月 15, 2007 12:15 pm
文章: 947
來自: Tainan
我沒使用 rhinoart 與 rhinoresurf ....

大部分我碰到的情況是
轉進 sw ,自動縫合後, 曲面間隙 會比原來好很多...

除非 原本的邊界 就沒處理好...


proe ....請用sw的檔案格式給他,會比較好一點...

.

_________________
我的部落格 http://arkuo.blogspot.com/


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 10月 31, 2011 1:53 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
感謝阿國的解答~
我想應該也是邊界上的問題!!
目前正在試0.0001的公差重新修剪曲面,希望能有好消息!!

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 10月 31, 2011 2:13 pm 
離線
VIP

註冊時間: 週五 6月 15, 2007 12:15 pm
文章: 947
來自: Tainan
我覺得是有些邊界變形的關係...
你把圖從 sw 裡面重轉出來 (step)
看哪些曲面的邊界有變形
把那些重修一下就好了...

我試過
公差 0.01mm 的物件
在sw裡面 也是可以自動縫的很漂亮...

.

_________________
我的部落格 http://arkuo.blogspot.com/


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 10月 31, 2011 6:51 pm 
離線
user

註冊時間: 週二 1月 29, 2008 12:48 pm
文章: 75
pipip 寫:
精度該調整多少會比較合適呢??


接手後續實體作業的軟體內定精度是多少單位 精度就用多少單位

如果對方是 0.001mm 也不用故意比它小 會用這種精度的軟體內會有配套 可以局部忽略公差 讓東西縫的起來 可以長肉做後續的工作

所以0.0001 別用 (這應該是半導體製程在用的經度XD)

這種精度 做出來的面 開節點來看會多到爆炸 尤其是Patch補面


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週二 11月 01, 2011 2:02 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
0.0001 的公差的確沒有比較好~等很久然後顯示記憶體不足,很容易當掉= =
物體是一個瓶蓋圓柱體側面有浮雕2條龍,主要問題在於STEP轉進SW後~浮雕圖案附著的那個圓柱側面會消失(浮雕本身沒事,浮在半空中)
畫了很久,卡在轉檔後無法實體化的部分!!

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週二 11月 01, 2011 2:40 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
如附圖!!圓柱的那個面消失了
如果說是gap太多,我在rhino用show edge卻是ok的!!
精度的話 我記得我一開始也有0.001
真不知道該怎麼處理了!!
請各位高手幫幫忙~
感謝
附加檔案:
檔案註釋: 圓柱的那個面消失了
面消失了.jpg
面消失了.jpg [ 372.77 KiB | 被瀏覽 132 次 ]

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週二 11月 01, 2011 3:56 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1894
來自: Tainan
給Solidworks建議使用Parasolid(*.x_t)檔案格式。如果因為STEP檔導致圓柱體的曲面不見,試試看先在Rhino以Split Isocurve將圓柱體切成兩個180度的半圓,看看有沒有幫助。


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週二 11月 01, 2011 4:16 pm 
離線
VIP

註冊時間: 週五 6月 15, 2007 12:15 pm
文章: 947
來自: Tainan
Cafer 寫:
給Solidworks建議使用Parasolid(*.x_t)檔案格式。如果因為STEP檔導致圓柱體的曲面不見,試試看先在Rhino以Split Isocurve將圓柱體切成兩個180度的半圓,看看有沒有幫助。


圓球面會變形 也是用同樣的方法...

.

_________________
我的部落格 http://arkuo.blogspot.com/


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週二 11月 01, 2011 6:12 pm 
離線
user

註冊時間: 週二 1月 29, 2008 12:48 pm
文章: 75
Cafer 寫:
給Solidworks建議使用Parasolid(*.x_t)檔案格式。如果因為STEP檔導致圓柱體的曲面不見,試試看先在Rhino以Split Isocurve將圓柱體切成兩個180度的半圓,看看有沒有幫助。

對半切再一票~~如果還不行的話加上 ShrinkTrimmedSrf


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週三 11月 02, 2011 2:45 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
hi 感謝各位的熱心解答
問題已解決囉^^
轉成x_t檔的確比較好,面沒有消失了!

在別的網站有網友說把模型縮小10倍後調整精度~再放大10倍的怪招,爾後再找時間試試(但這方法感覺好像不是很優)

而對半切圓與ShrinkTrimmedSrf的方法
這一兩天會找時間測試,感謝大家提點^^

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週四 11月 03, 2011 5:18 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
真怪了~家裡用的sw竟無法匯入x_t的檔案~
一拖曳進去sw就會顯示"無效資料" ~
不知道大家知道原因否???

作業環境是win7_64位元,sw是2010 edition

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週六 12月 03, 2011 6:08 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1894
來自: Tainan
沒人回你............

狀況依舊?家裡的Solidworks版本跟公司的不同?


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 1月 02, 2012 2:21 pm 
離線
user
頭像

註冊時間: 週三 6月 29, 2011 9:50 am
文章: 79
確實沒人回我啊~(淚
還好有大大的關心^^
~我想可能是檔案有問題吧~
12月份節日太多,忙著玩樂^^"
會找時間處理的,新年快樂唷~

_________________
Owen


回頂端
 個人資料  
 
 文章主題 : Re: 關於rhino轉檔到sw及pro-e的問題...
文章發表於 : 週一 1月 02, 2012 4:14 pm 
離線
版主
頭像

註冊時間: 週五 6月 08, 2007 3:33 pm
文章: 1894
來自: Tainan
反正你喜歡搞失蹤,早就不理你了~


回頂端
 個人資料  
 
顯示文章 :  排序  
發表新文章 回覆主題  [ 21 篇文章 ]  前往頁數 12  下一頁

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯文章
不能 在這個版面刪除文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
正體中文語系由 竹貓星球 維護製作